0
You have 0 items in your cart
Wordpress 5.0 ¿actualizar o no actualizar?

WordPress 5.0 ¿actualizar o no actualizar?

La versión 5.0 trae más que una actualización es un cambio enorme en el core de WordPress y la base de datos, además incorpora el editor Gutengerg del que ya hablé hace tiempo en este post.

Tras meses de retraso por fin ha salido a la luz esta actualización mayor de WP, los cambios son grandes y se busca con ellos hacerlo más fácil de usar y añadir funcionalidades dentro de los post de forma más sencilla sin necesitar saber nada de código.

Ya hablé hace bastantes meses sobre lo poco que me gustaba este cambio en un post sobre qué es Gutenberg y los problemas que iba a dar los sigue dando…

Es necesario u obligatorio actualizar a WordPress 5.0

No, ni de broma, aunque siempre desde el escritorio te recomiendan actualizar, no lo hagas, mi consejo que es lo que voy a hacer esperarme hasta marzo, no me apetece tener problemas en el blog ahora que es su época del año, además no me gustaría aparcar la cantidad de trabajo que tengo por arreglar errores y pantallas blancas.

Deja que los desarrolladores y los expertos se coman estos marrones encuentren errores, arreglen compatibilidades y cuándo todo el mundo tenga WordPress 5.0 actualiza si técnicamente puedes hacerlo.

Si estás deseando probarlo haz una versión en local e instalálo a ver que tal funciona, si le colocas tu theme, tus plugins y funciona te puedes lanzar a la piscina!.

Por qué no debes actualizar corriendo a la versión 5.0 de WordPress:

Tus temas y tus pluging quizás no estén listos para soportar la actualización, por ejemplo las personas que tengan DIVI deben actualizar a la nueva versión antes de actualizar WordPress, esto es un problema porque si se hace después puede que no consigas recuperar cambios que hayas hecho.

WordPress 5.0 se ha desarrollado en php 7.3 una versión de PHP que aún no es estable 100% con la que no funcionan muchos plugins, funciona con la versión a partir de la 7.1 y anteriores también pero es recomendable aumentar la versión para que no tengas problemas de funcionalidades.

Los plugins necesitan adaptarse, aunque es recomendable actualizar, en este caso espera un poco para evitar que dejen de funcionar (casi lo mejor que te puede ocurrir)

Otro tema importante es que aunque la comunidad de WordPress se deja las pestañas intentando que salga la versión impecable, la primera puede aún tener bugs y es mejor que esperes.

Si no necesitas el diseño por bloques… Gutenberg te va a sobrar y querrás volver al editor clásico, esto es posible mediante plugins el oficial del WordPress es Classic Editor

 

Cómo empezar la transición para evitar problemas de compatibilidad

Pregunta en tu hosting si tienes copias de bases de datos o si tienes las versiones correctas de bases de datos (MySQL, MongoDB, MariaDB…) para soportar los cambios que tendrás que hacer.

Haz una copia de la base de datos para recuperar tu blog si hay problemas.

Tienes que comprobar la versión de PHP que tienes rulando en tu web, si está por debajo de la 7.1 intenta que te la actualicen si los plugins la soportan.

Por si hay algún tipo de problema, te recuerdo que al igual que tú hay mucha gente que actualizará y puede que los servicios técnicos se colapsen, por eso si no eres muy «pro» con la tecnología espera unas semanitas…

Limpia de tu instalación todos los Themes y plugins que no utilizas, no sólo inactivos, también elimina plugins tontos.

No actualices nada sin enterarte qué debes actualizar primero si el Theme o Plugin o la versión de WordPress.

Para hacerlo correctamente debes ir a la web oficial del plugin o desarrollador y ver si han actualizado o si han publicado algo al respecto, si no lo hay o no dejan claro que es compatible y si hay que actualizarlo antes de la actualización de wordpress, ponte en contacto con ellos y que te lo aclaren.

En el propio panel de WordPress puedes verlo en plugins ver detalles y en el informa de cambios debería aparecer, en este caso en Contact Form 7 no aparece.

Wordpress 5.0 ¿actualizar o no actualizar?

Hay plugins muy utilizados que están dando problemas:

Bakery Builder

WPML

Advanced custom fields

Hay plugins como Revolution Slider, Ithemes Security que no han actualizado todavía.

En el caso de WooCommerce hay que actualizar WooCommerce antes de actualizar WordPress, por cierto esta actualización funciona un poco mal de momento.

En el caso de DIVI hay que actualizar DIVI antes de actualizar WordPress.

Por ejemplo StudioPress la empresa a la que pertenece Genesis Framework ha hecho los deberes y es compatible con Gutemberg en themes.

 

 

Los bloques dan flexibilidad pero ahora van a dar más problemas

Como puedes ver en el vídeo son fáciles de usar y es verdad que van a abrir muchas posibilidades en el uso de WordPress.

 

Twenty Nineteen el theme que trae WordPress 5.0

Han desarrollado un theme para que podamos probar y trabajar con las nuevas funcionalidades de Gutenberg, es un theme sencillo en el que puedes probar si te gusta o no el editor, lo puedes ver en acción en el sitio de Matt Mullenweg 

Bebo es el nombre que tiene esta versión, como todas las versiones de WordPress tienen nombre de músicos de Jazz ya que Matt Mullenweg es tan aficionado como yo.

Espero que no te precipites y no la líes demasiado parda, por favor pregunta a los desarrolladores y no actualices a la ligera.

 

0/5 (0 Reviews)
1 Response

Leave a Reply

Pin It on Pinterest

Share This